Вопрос по информатике:
Найдите сумму простых чисел, расположенных в интервале от числа 256 до числа 16384 включительно. В ответе запишите одно целое число.
- 05.12.2017 19:37
- Информатика
- remove_red_eye 12617
- thumb_up 10
Ответы и объяснения 2
Var
i,j,b,c:integer;
begin
c:=0;
for i:=256 to 16384 do
begin
b:=1;
for j:=2 to i div 2 do
if i mod j=0 then
begin
b:=0;
break;
end;
if b=1 then c+=i;
end;
writeln(c);
end.
Вывод:
14578560
- 07.12.2017 00:01
- thumb_up 15
Dim k as integer ' Объявляем глобальную переменную
Sub Prog_Summa()
Dim S as long, i as long
S = 0 ' В переменной S накапливается сумма простых чисел
for i=256 to 16384 ' цикл по всем числам, которые надо проверить
k=1 ' признак простого числа
Prost(i) ' В функции проверяем, что число i простое
if k = 1 then S = S + i ' если i - простое, прибавляем его к S
next i
print S ' Выводим сумму S
end sub
Function Prost(x)
Dim i as long, Q as long
Prost = 0 ' Значение функции пока равно 0
Q = int(sqrt(x)) ' Q=[√(x)] - предел проверки числа x на простоту
for i = 2 to Q
if int(x/i) = x/i then k=0 ' если х делится на i, то оно составное
next i
if k = 1 then Prost = x ' если x простое, то функция равна x
' Если x - составное, то функция остается равной 0
End Function
- 07.12.2017 02:18
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.