Вопрос по информатике:
Написать программу печати чисел Фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду Фибоначчи.
Помогите с программой на паскале .
- 14.12.2017 00:54
- Информатика
- remove_red_eye 10308
- thumb_up 50
Ответы и объяснения 1
function prost(n:longint):boolean;
var j,m:integer;
begin
m:=0;
for j:=2 to trunc(sqrt(n)) do
if n mod j = 0 then inc(m);
prost:=m=0;
end;
begin
f1:=1; f2:=1;
writeln('№ - Число');
writeln('1 - ',f1);
s:=1; k:=2;
while s<=1000 do
begin
if prost(s) then writeln(k,' - ',s);
inc(k);
s:=f1+f2;
f1:=f2;
f2:=s;
end;
end.
Результат:
№ - Число
1 - 1
2 - 1
3 - 2
4 - 3
5 - 5
7 - 13
11 - 89
13 - 233
- 14.12.2017 10:58
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.