Вопрос по информатике:
Уровень А. (оценка 3). Напишите программу, которая выводит M линий из символа S, заданного пользователем длиной N символов. При запуске программы M, N, S нужно ввести с клавиатуры. Пример: Количество линий: 2. Длина цепочки: 7. Символ-заполнитель: - ------- ------- Для реализации программы напишите процедуру Line, которая принимает два параметра – символ-заполнитель S и натуральное число N, и выводит на экран одну линию из символов S длиной N. Пример: Длина цепочки: 7. Символ-заполнитель: - -------
- 06.04.2016 06:11
- Информатика
- remove_red_eye 17619
- thumb_up 18
Ответы и объяснения 1
Var
m,n,i:integer;
s:char;
procedure line(c:char;n:integer);
Var
i:integer;
begin
for i:=1 to n do
write(c);
writeln;
end;
begin
readln(m,n);
readln(s);
for i:=1 to m do
line(s,n);
end.
Пример ввода:
2
7
-
Пример вывода:
-------
-------
- 07.04.2016 21:01
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.