Вопрос по информатике:
Задача на c++
Требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран.
Формат входных данных
Входной поток содержит целое число x (1000≤x≤9999)
Формат выходных данных
Выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.
- 19.04.2015 11:48
- Информатика
- remove_red_eye 14359
- thumb_up 27
Ответы и объяснения 2
using namespace std;
int main()
{
int a, b;
cout <> a, cout << "\n";
b = a/1000;
cout << b << "\n";
b = a/100 % 10;
cout << b << "\n";
b = a % 100 / 10;
cout << b << "\n";
b = a % 10;
cout << b << "\n";
return 0;
}
Пример:
a = 7052
7
0
5
2
- 21.04.2015 05:28
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
