Вопрос по информатике:
Помогите, пожалуйста! Нужно написать программу для АВС паскаль. Программа должна переводить обыкновенные числа в двоичную систему счисления. Заранее большое спасибо! 87 баллов!!
- 23.07.2016 13:36
- Информатика
- remove_red_eye 12890
- thumb_up 39
Ответы и объяснения 2
a: integer;
function p(x: integer): string;
var
s: string;
begin
s := '';
while x > 0 do
begin
s := chr(ord('0') + x mod 2) + s;
x := x div 2;
end;
p := s;
end;
begin
readln(a);
writeln(p(a));
end.
- 25.07.2016 00:09
- thumb_up 40
s:string;
begin
write('n = ');
readln(n);
m:=n;
s:='';
while m>0 do
begin
if m mod 2=0
then s:='0'+s else s:='1'+s;
m:=m div 2;
end;
writeln(s);
end.
Пример:
n = 115
1110011
- 25.07.2016 07:22
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.