Вопрос по информатике:
В файле в столбик записаны целые числа. Напишите программу, которая определяет количество пар соседних чисел таких, что предыдущее число меньше последующего, и выводит результат в конец исходного файла.
- 05.05.2018 15:37
- Информатика
- remove_red_eye 6224
- thumb_up 46
Ответы и объяснения 1
#include
int main(void)
{FILE* f;
int counter=0,pre,next,b=1;
f=fopen("input.txt","r");
fscanf(f,"%d",&pre);
if (feof(f))
b=0;
else
fscanf(f,"%d",&next);
while (!(feof(f)) && b)
{if(pre
pre=next;
fscanf(f,"%d",&next);}
if(pre
fclose(f);
f=fopen("input.txt","a");
fprintf(f,"\n%d",counter);
fclose(f);
return 0;}
Пример содержимого input.txt до работы программы:
12
123124124
2132134
12412
123123312
12
12345
Пример содержимого input.txt после работы программы:
12
123124124
2132134
12412
123123312
12
12345
3
- 06.05.2018 12:22
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.