Вопрос по информатике:
Помогите, пожалуйста, с задачей на паскаль. (В решение есть ошибки. Как написать код правильно?)
Два поезда из разных населенных пунктов одновременно выезжают навстречу друг другу и через t часов они встретились. Еще через t1
часов первый поезд прибыл в пункт, из которого выехал второй поезд. Через какое время второй поезд прибудет в пункт, из которого выехал первый поезд.
Входные данные
Два целых неотрицательных числа t и t1 (не превосходят 24).
Выходные данные
Вывести время, через которое второй поезд прибудет в конечный пункт в формате часы минуты.
var t,t1,t2,a,a1,x,x1:real;
begin
read(t);
read(t1);
a:=t*60;
a1:=t1*60;
t2:=a*a/a1;
x:=t2 div 60;
x1:=t2 mod 60;
writeln(t2:0:0,' ',x:0:0,' ',x1:0:0);
end.
- 24.06.2018 17:09
- Информатика
- remove_red_eye 19831
- thumb_up 11
Ответы и объяснения 2
Ради работоспособности придётся либо менять алгоритм, либо жертвовать точностью, округляя t2:
var
t, t1, t2, a, a1, x, x1: real;
begin
readln(t);
readln(t1);
a := t * 60;
a1 := t1* 60;
t2 := (a * a) / a1;
x := t2 div 60;
x1 := Round(t2) mod 60;
writeln(t2:0:0,' ',x:0:0,' ',x1:0:0);
end.
- 25.06.2018 02:44
- thumb_up 42
begin
readln(t);
readln(t1);
t2:=t*t/t1;
x:=trunc(t2);
x1:=frac(t2)*60;
writeln(t2,' ',x:0:0,' ',x1:0:0);
end.
Пример:
4.5
3
6.75 6 45
- 26.06.2018 05:49
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.