Вопрос по информатике:
Написать программу, позволяющую по последней цифре числа определить последнюю цифру его квадрата.
- 22.09.2017 13:16
- Информатика
- remove_red_eye 3390
- thumb_up 32
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(0,1,4,9,6,5,6,9,4,1);
var i:=ReadInteger('Введите натуральное число:') mod 10;
Writeln('Последняя цифра квадрата введенного числа- ',a[i])
end.
Пример
Введите натуральное число: 76649
Последняя цифра квадрата введенного числа- 1
- 23.09.2017 06:20
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.