Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0-признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ
- 16.01.2018 20:44
- Информатика
- remove_red_eye 17790
- thumb_up 36
Ответы и объяснения 1
var i,n,k: integer;
s: longint;
begin
s :=0; k :=0;
repeat
readln ( i );
s:=s+i;
if ( i 0) and ( i mod 2=0) and ( i mod 5=0) then k:=k+1;
until i=0;
writeln ('s= ',s, ' ', 'k= ',k);
end.
- 17.01.2018 06:20
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.