Вопрос по информатике:
Даны натуральные числа m и n (m<n).
составить программу, печатающую все натуральные числа больше m, но меньше n, а также сумму этих чисел.
в программе Паскаль
- 26.10.2017 09:12
- Информатика
- remove_red_eye 1016
- thumb_up 30
Ответы и объяснения 1
begin
write('m = ');
readln(m);
write('n = ');
readln(n);
s:=0;
for i:=m+1 to n-1 do
begin
write(i,' ');
s:=s+i;
end;
writeln;
writeln('s = ',s);
end.
Пример:
m = 5
n = 10
6 7 8 9
s = 30
- 27.10.2017 04:40
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.