Вопрос по информатике:
Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. Надо написать на Паскале, объяснить при этом всё, ещё и блок схему надо
- 15.03.2015 10:48
- Информатика
- remove_red_eye 15918
- thumb_up 47
Ответы и объяснения 2
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
- 16.03.2015 13:04
- thumb_up 38
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
- 17.03.2015 03:17
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.