Вопрос по информатике:
Задача на c++
Даны два числа d и l. Требуется найти первые 15 натуральных чисел, не меньших, чем l и делящихся нацело на d.
Формат входных данных
На вход программе дается два натуральных числа d и l, не превосходящих 10 в 7 степени.
Формат выходных данных
Требуется вывести возрастающую последовательность чисел — ответ на задачу.
- 05.02.2016 03:56
- Информатика
- remove_red_eye 7370
- thumb_up 34
Ответы и объяснения 1
using namespace std;
int main(){
int d,l,a,i;
cout <> d, cout << "\n";
cout <> l, cout << "\n";
a = (l-1)/d*d+d;
for(i=0; i < 15; i++){
cout << a+d*i << " ";
}
cout << "\n";
return 0;
}
Пример:
d = 5
l = 12
15 20 25 30 35 40 45 50 55 60 65 70 75 80 85
- 06.02.2016 00:05
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.