Вопрос по информатике:
Дам 25 баллов
В двумерном массиве хранится информация о количестве учеников в каждом классе каждой параллели школы с первой по одиннадцатую (в первом столбце — информация о классах первой параллели, во втором — второй параллели и т. д.). В каждой параллели школы учатся 5 классов. Составить программу для расчета общего числа учеников в любой параллели.
- 19.10.2016 19:56
- Информатика
- remove_red_eye 14079
- thumb_up 44
Ответы и объяснения 1
n=5;
m=11;
var
a: array[1..n,1..m] of integer;
i,j,s: integer;
begin;
s:=0;
writeln ('Количество учеников по классам:');
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(25,30);
write (a[i,j]:3);
end;
writeln;
end;
writeln;
write ('Введите номер параллели: ');
readln (j);
for i:=1 to n do
s:=s+a[i,j];
writeln ('В ',j,'-ой параллели всего ',s,' учеников');
end.
----------------Результат:---------------------
Количество учеников по классам:
27 27 28 26 28 25 27 25 27 29 26
25 29 25 26 29 26 29 26 27 27 29
30 25 29 27 25 28 29 27 29 26 28
25 26 27 27 30 29 25 30 26 28 25
28 26 28 27 28 28 25 27 28 26 30
Введите номер параллели: 5
В 5-ой параллели всего 140 учеников
- 20.10.2016 09:25
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.