Вопрос по информатике:
Написать программу в паскаль
Ввести текст состоящий из слов , разделённых между собой запятыми.
Сколько раз в тексте встречается слова "Мама" В найденных словах изменить букву "М" на букву "П"
Так же нужно прописать программу простую и понятную по синтаксису
- 08.07.2018 02:45
- Информатика
- remove_red_eye 17482
- thumb_up 37
Ответы и объяснения 1
begin
var s := ReadlnString('>');
var r := new Regex('\bМама\b');
Writeln('Количество слов "Мама": ', r.Matches(s).Count);
s := r.Replace(s, 'Пама');
s.Println;
end.
все просто и понятно)
только экранирующие символы пришлось поискать для слова целиком
Пример работы программы:
> Мама,Мамам,Мама,мама,Мама
Количество слов "Мама": 3
Пама,Мамам,Пама,мама,Пама
- 09.07.2018 20:50
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.