Вопрос по информатике:
Напишите программу вычисления наименьшего общего кратного следующих четырех чисел:36,54,18 и 15.Используйте процедуру вычисления наибольшего общего делителя двух чисел.
- 03.07.2018 23:12
- Информатика
- remove_red_eye 19031
- thumb_up 9
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function gcd(a,b:int64):int64; // НОД
begin
while b0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
Writeln(gcd(gcd(36,54),gcd(18,15)))
end.
Результат
3
- 04.07.2018 12:01
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.