Вопрос по информатике:
Написать программу в паскаль
Ввести текст состоящий из слов , разделённых между собой запятыми.
Сколько раз в тексте встречается слова "Мама" В найденных словах изменить букву "М" на букву "П"
- 01.07.2016 07:53
- Информатика
- remove_red_eye 12619
- thumb_up 16
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var a:=s.ToWords(',');
Writeln('Количество слов "Мама": ',a.Where(w->w='Мама').Count);
s:=(s+',').Replace('Мама,','Пама,'); Delete(s,s.Length,1);
s.Println
end.
Пример
> Мама,мама,что,я,буду,делать,Мама,мама,как,я,буду,жить
Количество слов "Мама": 2
Пама,мама,что,я,буду,делать,Пама,мама,как,я,буду,жить
- 02.07.2016 20:44
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.