Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму четных чисел. Программа получает на вход количество чисел в последовательности, а сами числа задаются случайным образом. Количество чисел не превышает 100. Введённые числа не превышают 50. Программа должна вывести исходные числа и число- сумму четных чисел. С ОБЪЯСНЕНИЕМ ОТВЕТА, спасибо.
- 10.05.2015 11:20
- Информатика
- remove_red_eye 6568
- thumb_up 9
Ответы и объяснения 1
var mass:array[1..100] of integer;
g,s,i,sum:integer;
begin
sum:=0;i:=0; // задаем начальное значение счетчику
randomize; //рандомизация
writeln('введите количество чисел в массиве (до 100)');
readln(g); // водим количество чисел
for s:=1 to g do // от нуля, до кол-ва чисел в массиве
begin
i:=i+1;
mass[i]:=random(51); //51 потому что всегда -1 еще идет...
if (mass[i] mod 2) = 0 then sum:=sum+mass[i]; //проверяем на четность и плюсуем, если четное.
writeln(mass[i]);
end;
writeln('чисел в массививе - '+g); //выводим значенияwriteln('сумма четных элементов = '+sum);
end.
- 11.05.2015 08:13
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.