Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА, НУЖНО ДО ЗАВТРА! ДАЮ 99 БАЛЛОВ!
1. Выполните следующие задания:
a) Найдите ошибки в записи оператора ветвления, запишите правильный вариант фрагмента программы:
if x:=y then;
x:=0;
y:=0; end;
else
write(z);
b) По блок-схеме составьте программу. (Блок-схема в прикреплённом файле)
2. Даны три числа. Возвести в куб те из них, которые нечетны. Остальные оставить без изменения.
3. Нарисовать на плоскости (х,у) область, в которой истинно указанное выражение: (y>=x) and (y+x>=0) and (y<=1).
- 09.08.2018 18:17
- Информатика
- remove_red_eye 3768
- thumb_up 42
Ответы и объяснения 2
else write (z);
2. Var a,b,c,d:Integer;
Begin
read (a,b,c);
if a>b then d:=a
else d:=b;
if c>d then d:=c;
Write (d)
end.
- 01.01.1970 00:00
- thumb_up 7
if x=y
then begin x:=0; y:=0; end
else write(z);
б)
var a,b,c,d:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if a>b then d:=a else d:=b;
if c>d then d:=c;
writeln(d);
end.
Пример:
a, b, c:
2 8 5
8
2)
var a,b,c:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if a mod 2 0 then a:=a*a*a;
if b mod 2 0 then b:=b*b*b;
if c mod 2 0 then c:=c*c*c;
writeln('a = ',a,' b = ',b,' c = ',c);
end.
Пример:
a, b, c:
5 2 7
a = 125 b = 2 c = 343
3)
Решение - в прилагаемом файле.
- 01.01.1970 00:00
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.