Вопрос по информатике:
ПОЖАЛУЙСТА ПОМОГИТЕ! ПРОШУ ВАС ЧИСТО СЕРДЕЧНО ПОМОЧЬ МНЕ((
1) Выберите из предложенных полные записи оператора if:
a)
if x>y then begin if x>0 then x:=0 else y:=0; end else x:=y c)
if x>y then x:=0 else y:=0;
b)
if x>y then
begin
x:=0;
y:=0;
end; d)
if x>y then
begin
x:=0; y:=0;
end;
2) Запишите оператор ветвления в общем виде.
3) Выполните следующие задания:
a) Найдите ошибки в записи оператора ветвления, запишите правильный вариант фрагмента программы:
if x:=y then;
x:=0;
y:=0; end;
else
write(z);
b) По блок-схеме составьте программу.
4) Даны три числа. Возвести в куб те из них, которые нечетны. Остальные оставить без изменения.
5) Нарисовать на плоскости (х,у) область, в которой истинно указанное выражение: (y>=x) and (y+x>=0) and (y<=1).
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 24.09.2015 07:41
- Информатика
- remove_red_eye 4383
- thumb_up 26
Ответы и объяснения 2
begin
readln(a,b,c);
if a mod 2=1 then writeln(a*a*a);
if b mod 2=1 then writeln(b*b*b);
if c mod 2=1 then writeln(c*c*c);
end.
5. Опять же некорректная задача. В каком смысле нарисовать?
- 25.09.2015 15:21
- thumb_up 41
2) if then else
3) а)
if x=y
then begin x:=0; y:=0; end
else write(z);
б) - нет блок-схемы
4)
var a,b,c:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if a mod 2 0 then a:=a*a*a;
if b mod 2 0 then b:=b*b*b;
if c mod 2 0 then c:=c*c*c;
writeln('a = ',a,' b = ',b,' c = ',c);
end.
Пример:
a, b, c:
5 2 7
a = 125 b = 2 c = 343
5)
Решение - в прилагаемом файле.
- 26.09.2015 13:00
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.