Вопрос по информатике:
Ребят помогите очень срочно !!!! Мне завтра её сдавать ,а у меня не получается.
Я люблю информатику и обычно сам всё решаю ,но тут встал в тупик,помогите!!!
ДАЮ 54 БАЛЛА!!!
(ЯЗЫК Pascal ABC)
Дано число X. Требуется перевести это число в римскую систему счисления.
Входные данные
Дано число X в десятичной системе счисления (1 ≤ X ≤ 100).
Выходные данные
Выведите X в римской системе счисления.
Примеры
входные данные
4
выходные данные
IV
входные данные
19
выходные данные
XIX
входные данные
46
выходные данные
XLVI
- 15.05.2017 09:07
- Информатика
- remove_red_eye 3775
- thumb_up 10
Ответы и объяснения 1
d:string[45];
begin
SetConsoleOutputCP(1251);
writeln('Введите число в диапазоне от 1 дo 100');
write('a=');
readln(a);
b:=a mod 10;
a:=a div 10;
case b of
0: d:='';
1: d:='I';
2: d:='II';
3: d:='III';
4: d:='IV';
5: d:='V';
6: d:='VI';
7: d:='VII';
8: d:='VIII';
9: d:='IX';
end;
b:=a mod 10;
a:=a div 10;
case b of
0: d:=''+d;
1: d:='X'+d;
2: d:='XX'+d;
3: d:='XXX'+d;
4: d:='XL'+d;
5: d:='L'+d;
6: d:='LX'+d;
7: d:='LXX'+d;
8: d:='LXXX'+d;
9: d:='XC'+d;
end;
b:=a mod 10;
a:= a div 10;
case b of
0: d:=''+d;
1: d:='C'+d;
end;
writeln('B Римской системе счисления ' ,d);
readln;
end.
- 16.05.2017 16:46
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.