- 11.01.2017 18:51
- Информатика
- remove_red_eye 16905
- thumb_up 16
Ответы и объяснения 1
//Pascal ABC.Net
Var a:array[1..4] of longint;i,min:longint;nom:byte;
Begin
for i:=1 to 4 do
read(a[i]);
min:=a[1];
nom:=1;
for i:=2 to 4 do
if (a[i]
if (inom) then write(a[i],' ')
else begin write(a[i]*a[i],' '); nom:=0; end;
writeln;
End.
Тесты
Входные данные: 2 3 4 5
Выходные данные: 4 3 4 5
Входные данные: 10000 10001 10002 10003Выходные данные: 100000000 10001 10002 10003
2) Зарезервированные слова - проще говоря, это слова, которые нельзя указывать как имена переменных или констант. Список всех слов в языке Паскаль:
Absolute — Абсолютный
And — Логическое И
Array — Массив
Begin — Начало блока
Const — Константа
Div — Деление нацело
Goto — Переход на
Do — Выполнять
Downto — Уменьшить до
Else — Иначе
End — Конец блока
File — Файл
For — Для
Function — Функция
If — Если
Interrupt — Прервать
Interface — Интерфейс
Label — Метка
Library — Библиотека
Mod — Остаток от деления на
Not — Логическое НЕ
Or — Логическое ИЛИ
Of — Из
Object — Объект
Procedure — Процедура
Program — Программа
Repeat — Повторять
String — Строка
Then — Тогда
To — Увеличивая
Type — Тип
Until — До
Uses — Использовать
Var — Переменная
While — Пока
With — С
Xor — Исключающее ИЛИ
И т.д.
В основном при написании они все выделяются жирным шрифтом (в Pascal)
3)
1. Имя программы
2. Раздел подключения модулей
3. Раздел описаний
Begin
4. Операторы
End.
- 12.01.2017 20:04
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.