Вопрос по информатике:
Составьте программу, которая заполняет массив a [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму эелементов с чётными значениями и количиство элементов с нечётными значениямиъ
- 12.08.2018 14:11
- Информатика
- remove_red_eye 11587
- thumb_up 38
Ответы и объяснения 1
f: array[1..10] of integer;
i,suma,sumb:integer;
begin
randomize;
for i:=1 to 10 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
suma:=0;
sumb:=0;
for i:= 1 to 10 do
if f[i] mod 2 = 0 then
suma:=suma+f[i];
else
sumb:sumb+f[i];
writeln('Сумма четных: ',suma);
writeln('Сумма нечетных: ',sumb);
end.
var
f: array[1..8] of integer;
i,k,sumb:integer;
begin
randomize;
for i:=1 to 8 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
k:=0;
sumb:=0;
for i:= 1 to 8 do
if f[i] mod 2 = 0 then
k:=k+1;
else
sumb:sumb+f[i];
writeln('Количество четных: ',k);
writeln('Сумма нечетных: ',sumb);
end.
- 13.08.2018 20:57
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.