Вопрос по информатике:
Очень срочно
20 баллов
1. Составьте программу, которая формирует мас- сив из шестнадцати случайных целых чисел от-20 до 20 и: a) находит элементы с нулевыми значениями, б) находит индексы четных элементов; в) подсчитывает количество отрицательных эл ементов г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем, д) находит в этом массиве индексы алементов значения которых кратны трем.
На экран выводятся исходный массив и найденные элементы
- 16.08.2018 09:41
- Информатика
- remove_red_eye 18785
- thumb_up 40
Ответы и объяснения 1
uses CRT;
const N=16;
var a:array[1..N] of integer; i:integer;
begin
for i:=1 to N do
begin
a[i]:=random((41)-20);
end;
for i:=1 to N do
if a[i]=0 then
writeln('a[',i,']=0')
else
writeln('Нет нулевых элементов');
end.
- 17.08.2018 12:25
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.