Вопрос по информатике:
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.
- 19.06.2018 07:16
- Информатика
- remove_red_eye 13256
- thumb_up 47
Ответы и объяснения 1
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;
- 20.06.2018 17:52
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.