Вопрос по информатике:
Помогите пожалуйста написать программу на Паскаль: Создать две матрицы m x n и n x m, заполнить первую случайными числами, вывести на экран. Транспонировать первую матрицу во вторую и тоже вывести на экран.
- 14.10.2017 01:00
- Информатика
- remove_red_eye 19500
- thumb_up 25
Ответы и объяснения 1
x := x div 100;
x := x mod 10;
x := x * x;
writeln(x);
вроде так.
или вот так
var
n:longint;
begin
Write('Введите пятизначное натуральное число: ');
Read(n);
Writeln('Квадрат средней цифры равен ',
sqr((n div 100) mod 10))
end.
текстовое решение
Введите пятизначное натуральное число: 15624
Квадрат средней цифры равен 36
- 15.10.2017 07:25
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.