Вопрос по информатике:
Составьте программу вычисления в массиве А(10) заполненном случайными числами из интервала (-5,10) количества отрицательных элементов
- 25.09.2018 00:44
- Информатика
- remove_red_eye 8436
- thumb_up 37
Ответы и объяснения 1
//Для Pascal ABC.Net:
Var a:array[1..10] of longint;n,i,k:longint;
Begin
readln(n); //Читаем количество элементов в массиве
for i:=1 to n do
begin
read(a[i]); //Читаем каждый элемент в массиве
if (a[i]<0) then k+=1; //Увеличиваем счётчик k на 1, если элемент меньше нуля
end;
writeln(k); //Выводим счётчик k
End.
//Для Pascal ABC:
Var a:array[1..10] of integer;n,i,k:integer; //Простой Паскаль не поддерживает longint
Begin
readln(n);
for i:=1 to n do
begin
read(a[i]);
if (a[i]<0) then k:=k+1; //Отличие в том, что здесь нельзя просто увеличить с помощью +=, только с :=k+1
end;
writeln(k); //Выводим счётчик k
End.
- 25.09.2018 07:56
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.