Вопрос по информатике:
Нужно решение задачи в PascalABC и нарисованная блок-схема. Помогите пожалуйста.
Условие задачи:
В автоматизированной информационной системе содержатся анкетные данные сотрудников учреждения.
В массиве V(8) содержатся года рождения сотрудников,
В массиве P(8) – сведения о поле,
В массиве S(8) – сведения о семейном положении.
Элемент массива V с номером N – год рождения сотрудника N,
Элемент массива P с номером N – сведения о поле сотрудника N,
Элемент массива S с номером N – сведения о семейном положении сотрудника N.
P(N)=0, сотрудник N женского пола
P(N)=1, сотрудник N мужского пола
S(N)=0, сотрудник N холост (не замужем)
S(N)=1, сотрудник N женат (замужем)
Определить:
Минимальный возраст среди замужних женщин
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 16.09.2016 00:47
- Информатика
- remove_red_eye 7549
- thumb_up 22
Ответы и объяснения 1
i, j, n, min: integer;
v: array[1..8]of integer;
p: array[1..8]of integer;
s: array[1..8]of integer;
begin
min := 999;
for i := 1 to 8 do read(v[i]);
for i := 1 to 8 do read(p[i]);
for i := 1 to 8 do read(s[i]);
for i := 1 to 8 do if(p[i] = 0) and (s[i] = 1) and (v[i] < min) then min := v[i];
write(min);
end.
Пример:
Входные данные:
22 19 40 33 34 23 45 23
1 0 0 1 1 0 1 0
0 1 1 0 0 1 1 0
Выходные данные:
19
- 16.09.2016 00:23
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.