Вопрос по информатике:
Помогите составить программу по паскалю!
Определить количество чисел с цифрой 4 в записи числа
- 04.07.2018 05:54
- Информатика
- remove_red_eye 16121
- thumb_up 50
Ответы и объяснения 1
ar:array[1..2000] of integer;
n,i,count:integer;
begin
readln(n);
for i:=1 to n do begin
read(ar[i]);
while ((ar[i]>0) and ((ar[i] mod 10)4)) do ar[i]:=ar[i] div 10;
if ar[i] mod 10 = 4 then inc(count);
end;
writeln(count);
end.
- 05.07.2018 01:21
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.