Вопрос по информатике:
Составьте программу которая заполняет массив b [1...8] случайными целыми числами в диапазоне от 1 до 10 и находиь произведение элементов с нечетными значениями и количество элементов с четными значениями
- 16.12.2017 03:13
- Информатика
- remove_red_eye 17996
- thumb_up 23
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(8,1,10); a.Println;
Writeln('Произведение нечетных элементов ',
a.Where(x->x.IsOdd).Aggregate(1,(x,y)->x*y));
Writeln('Количество четных элементов ',
a.Where(x->x.IsEven).Count)
end.
Пример
9 10 10 5 8 3 5 2
Произведение нечетных элементов 675
Количество четных элементов 4
- 17.12.2017 02:32
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.