Вопрос по информатике:
Помогите пожалуйста составить программу: дан массив из 40, из него составить два массива, первый с четными положительными числами, а второй с остальными. рандом (-1000..1000) В ПАСКАЛЕ
- 12.08.2018 19:18
- Информатика
- remove_red_eye 14344
- thumb_up 33
Ответы и объяснения 1
var a,b,c:array [1..n] of integer;
i,i1,i2:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(2001)-1000;
write(a[i],' ');
end;
writeln;
i1:=0; i2:=0;
for i:=1 to n do
if (a[i] mod 2 = 0)and(a[i]>0)
then begin i1:=i1+1; b[i1]:=a[i]; end
else begin i2:=i2+1; c[i2]:=a[i]; end;
for i:=1 to i1 do write(b[i],' ');
writeln;
for i:=1 to i2 do write(c[i],' ');
writeln;
end.
Пример (для n=10):
46 -695 764 502 965 253 454 180 -123 980
46 764 502 454 180 980
-695 965 253 -123
- 13.08.2018 23:06
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.