Вопрос по информатике:
PascalABC
Нужно составить программу для вывода ближайшего степени 2-ки
- 05.02.2017 19:00
- Информатика
- remove_red_eye 17892
- thumb_up 46
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadInteger('Введите натуральное число:');
var p:=Round(log2(s));
Writeln('Два в степени ',p,' = ',power(2,p))
end.
Пример
Введите натуральное число: 4093532
Два в степени 22 = 4194304
- 06.02.2017 17:10
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.