Вопрос по информатике:
Паскаль абс
Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z. Определите, какая из кошек первой доберется до мыши, если кошки передвигаются с одной скоростью. В случае если кошки одновременно добираются до мышки, то тогда кошки ссорятся из-за добычи, и мышь ускользает от них. Формат входных данных Единственная строка входного файла содержит три целых числа x, y, z (1 <= x, y, z <= 1 000). Все числа различны. Формат выходных данных Если первая кошка доберется до мышки раньше второй выведите “1” (без кавычек). В случае если вторая кошка доберется до мыши раньше первой выведите “2” (без кавычек). В случае если мышка ускользает выведите “3” (без кавычек).
- 21.10.2017 08:16
- Информатика
- remove_red_eye 2201
- thumb_up 6
Ответы и объяснения 1
begin
readln(x,y,z);
if abs(x-z)
else if abs(x-z)>abs(y-z)
then writeln(2) else writeln(3);
end.
Пример:2 8 4
1
- 22.10.2017 06:15
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.