Вопрос по информатике:
В массиве хранятся сведения о количестве осадков(в мм),выпадавших ежедневно в сентябре.Составьте программу,которая подсчитывает количество дождливых дней (h [i] >0)
Люди помогите пожалуйста!Срочна надо,кому не трудно...
- 17.12.2017 22:29
- Информатика
- remove_red_eye 16303
- thumb_up 35
Ответы и объяснения 1
var
i,count:integer;
h: array [1..N] of integer;
begin
count:=0;
writeln('Введите количество осадков');
for i:=1 to N do
read(h[i]);
for i:=1 to N do
if h[i]>0 then
count:=count+1;
writeln('Количество дождливых дней ', count)
end.
В первой строке указываем количество дней. Это константа N
Далее объявляем, что переменная count равна 0. В этой переменной мы будем хранить количество дней с осадками.
Далее мы вводим с клавиатуры 30 чисел, показывающих осадки.
Потом мы проверяем, если число в массиве больше нуля, то мы увеличиваем count на единицу. Тоесть прибавляем +1 день с осадками.
В конце выводим количество дней с осадками
- 18.12.2017 00:39
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.