Вопрос по информатике:
ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить слова t из строки s. Строку s и слово t, которое надо удалить, введите с клавиатуры.
- 23.09.2018 07:32
- Информатика
- remove_red_eye 8628
- thumb_up 46
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadlnString('s=').Replace(ReadlnString('t='),''))
end.
Пример:
s= дождик, дождик, перестань!
t= дождик
, , перестань!
- 24.09.2018 18:10
- thumb_up 10
//PascalABC.NET 3.2 сборка 1318
Var
s,t,snew,curr,add,currsave:string;
i,j,flag:integer;
begin
readln(s);
readln(t);
//s=lowcase(s);
t:=lowercase(t);
while pos(' ',s)0 do
begin
flag:=0;
curr:=copy(s,1,pos(' ',s));
currsave:=curr;
if pos(t,lowercase(curr))0 then
begin
flag:=1;
delete(curr,pos(t,lowercase(curr)),length(t));
for j:=1 to length(curr) do
if ((curr[j]>='a') and (curr[j]='А') and (curr[j]='a') and (curr[j]='A') and (curr[j]<='Z')) then
flag:=0;
end;
if flag=1 then snew+=curr else snew+=currsave;
delete(s,1,pos(' ',s));
end;
curr:=s;
currsave:=curr;
flag:=0;
if pos(t,lowercase(curr))0 then
begin
flag:=1;
delete(curr,pos(t,lowercase(curr)),length(t));
for j:=1 to length(curr) do
if ((curr[j]>='a') and (curr[j]='А') and (curr[j]='a') and (curr[j]='A') and (curr[j]<='Z')) then
flag:=0;
end;
if flag=1 then
snew+=curr
else
snew+=currsave;
writeln(snew);
end.
Пример ввода:
Который из всех котов кот съел мясо
Пример вывода:
Который из всех котов съел мясо
- 25.09.2018 22:54
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.