Вопрос по информатике:
Помогите, пожалуйста, найти ошибки и доделать программу! Задание: Для приведенной ниже функции напишите программу, вычисляющую значение
функции в заданной точке x .
// isvc.cpp: определяет точку входа для консольного приложения.
//
#include "stdafx.h"
#include
#include
using namespace std;
int main()
{
double x, y, p;
const double PI = 3.14159265;
setlocale (LC_ALL, "rus_rus.1251");
cout <<" Введите значение х, в котором будет найдено значение функции "<< endl;
cin >> x;
{
if(fabs(x)>=-2 && fabs(x)<0)
return exp(2*x)-1;
if(fabs(x)>=0 && fabs(x) return sin(x);
if(fabs(x)>=PI/2 && fabs(x)<=6
return 1;
}
cout << " Значение функции в точке х равно ";
cout << y < system("pause");
return 0;
}
- 08.01.2015 18:44
- Информатика
- remove_red_eye 3956
- thumb_up 37
Ответы и объяснения 1
using namespace std;
int main(){ double x, y, p; const double PI = 3.14159265; setlocale(LC_ALL, "rus_rus.1251");
cout <> x;
if (fabs(x) >= -2 && fabs(x) < 0) y = exp(2 * x) - 1;
if (fabs(x) >= 0 && fabs(x)) y = sin(x);
if (fabs(x) >= PI / 2 && fabs(x) <= 6) y = 1;
cout << "Значение функции в точке х равно "; cout << y << endl;
system("pause"); return 0;}
- 09.01.2015 13:24
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.