Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет количество таких чисел, которые кратны 4 и оканчиваются на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 4 и оканчивающихся на 2. Пример работы программы:
Входные данные Выходные данные
12 140 22 0 1
- 24.07.2017 22:53
- Информатика
- remove_red_eye 2926
- thumb_up 14
Ответы и объяснения 1
var
count, x : integer;
begin
count := 0;
repeat
read (x);
if (x mod 4=0) and (x mod 10=4) then inc (count);
until x = 0;
writeln (count);
end.
- 25.07.2017 20:06
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.