Вопрос по информатике:
Помогите пожалуйста с заданием
1. В программе используется следующий массив под общим именем А: Индексы элементов 1 2 3 4 5 Значения элементов 9 8 7 6 5 a) Опишите этот массив, используя образец VAR имя_массива: ARRAY [N1..N2] OF базовый тип; b) Выпишите в тетрадь равенства, подставляя вместо многоточия нужные числа: а[2]= …, а[3]=…, а[…]=6. 2. Напишите последовательность команд для обмена значениями b[11] и b[14]. 3. Напишите программу, которая находит сумму всех элементов массива. 4. Напишите программу, печатающую отрицательные элементы массива. 5. Отрицательные элементы массива возвести в квадрат, положительные – в третью степень.
- 25.03.2018 12:37
- Информатика
- remove_red_eye 16229
- thumb_up 15
Ответы и объяснения 1
b) а[2]=8, а[3]=7, а[4]=6.
2. c:=b[11]; b[11]:=b[14]; b[14]:=c;
3.
var
a: array[1..10] of integer;
s,i: integer;
begin
s:=0;
for i:=1 to 10 do begin
read (a[i]);
s:=s+a[i];
end;
writeln (s);
end.
4.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0 then
writeln (a[i])
end
end.
5.
var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do begin
read (a[i]);
if a[i]<0
then a[i]:=a[i]*a[i]
else a[i]:=a[i]*a[i]*a[i];
write (a[i]:4)
end
end.
- 26.03.2018 11:09
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.