Вопрос по информатике:
Информатика. Составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 20.07.2015 09:36
- Информатика
- remove_red_eye 14775
- thumb_up 14
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,0,10); a.Println;
Writeln(a.Max+a.Min)
end.
Пример
6 5 4 7 5 8 8 10 0 2
10
- 21.07.2015 12:00
- thumb_up 40
#include
#include
void main( void )
{
int A[10], max = A[0], min = A[0], i;
for (i = 0; i < 10; i++)
{
A[i] = rand() / RAND_MAX * 10;
if (A[i] < min)
min = A[i];
if (A[i] > max)
max = A[i];
}
}
printf("Sum of min & max: %i", (max + min));
- 22.07.2015 15:48
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.