Вопрос по информатике:
Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.
- 18.04.2018 00:55
- Информатика
- remove_red_eye 3380
- thumb_up 19
Ответы и объяснения 2
uses System.Linq;var s: array of string;
a: string;
i, x: integer;begin
readln(a);
s := a.Split();
for i := 0 to s.Length - 1 do
if (s[i].Length 0) then
write(s[i] + ' ');
end.
- 19.04.2018 07:10
- thumb_up 10
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>').ToWords.JoinIntoString;
s.Println;
end.
Пример
> А роза упала на лапу Азора
А роза упала на лапу Азора
- 20.04.2018 21:50
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.