Вопрос по информатике:
Помогите пожалуйста с ИНФОРМАТИКОЙ!
В любом числе можно выделить некоторую непрерывную последовательность цифр, которая тоже будет некоторым числом. Требуется написать программу, которая находит максимальное натуральное число Х такое, что десятичная запись числа X^2 является подстрокой в десятичной записи числа N. Если такого числа нет, то вывести ноль.
Формат входных данных (допускается чтение с клавиатуры)
Вводится натуральное число N. 1 N 1 000 000 000.
Формат выходных данных (допускается вывод на экран)
Выведите максимальное натуральное число Х такое, что десятичная запись числа X2 является подстрокой в десятичной записи числа N.
- 07.02.2017 19:23
- Информатика
- remove_red_eye 5301
- thumb_up 5
Ответы и объяснения 1
//Очередное решение "в лоб"
Var
n,i,j,max:integer;
s,curr:string;
b:boolean=false;
begin
readln(n);
max:=-1;
s:=inttostr(n);
for i:=1 to length(s) do
begin
curr:='';
for j:=i downto 1 do
begin
curr:=s[j]+curr;
if frac(sqrt(strtoint(curr)))=0 then
begin
b:=true;
if sqrt(strtoint(curr))>max then max:=round(sqrt(strtoint(curr)));
end;
end;
end;
if b then writeln(max) else writeln('0');
end.
Пример ввода 1:
164
Пример вывода 1:
8
Пример ввода 2:
523
Пример вывода 2:
0
- 08.02.2017 00:31
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.