Вопрос по информатике:
Написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200см считает количество спортсменов рост которых больше 190см а также средний рост всех спортсменов
- 05.01.2018 05:32
- Информатика
- remove_red_eye 9720
- thumb_up 28
Ответы и объяснения 1
a: array [1..10] of integer;
i, s, k: integer;
begin
for i:=1 to 10 do
begin
Writeln('Рост спортсмена №',i,': ');
Readln(a[i]);
if a[i] > 190 then
k:=k+1;
s:=s+a[i];
end;
Writeln(k, ' спортсмена(-ов) рост, которых составляет более 190 см.');
Writeln('Средний рост всех спортсменов составляет ', s/10,' см.');
end.
- 06.01.2018 21:18
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.