Вопрос по информатике:
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа
2. Измените программу так, чтобы определялось произведение чисел.
3. измените программу так, чтобы определялось количество чисел, заканчивающихся на 8
- 21.06.2018 12:52
- Информатика
- remove_red_eye 7912
- thumb_up 32
Ответы и объяснения 1
var n, s: integer;
begin
WriteLn('Введите последовательность. Конец ввода - 0');
repeat
ReadLn(n);
if (n > 0) and ((n mod 10 = 8)) then
s := s + n
until n = 0;
WriteLn('Сумма чисел, оканчивающихся на 3 или 9 = ', s);
end.
- 22.06.2018 23:49
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.