Вопрос по информатике:
Заданы длины катетов прямоугольного треугольника. составьте программу,с помощью которой определите радиус вписанной и радиус описанной окружности.
- 16.11.2017 06:51
- Информатика
- remove_red_eye 3229
- thumb_up 33
Ответы и объяснения 1
с=кв.корень из (а^2+b^2)
r=(a+b-c)/2
R=c/2
var a,b,c,r1,r2: real;
begin
write ('введите катет а: ');
readln (a);
write ('введите катет b: ');
readln (b);
c:=sqrt(a*a+b*b);
r1:=(a+b-c)/2; //радиус вписанной окружности
r2:=c/2; //радиус описанной окружности
writeln;
writeln ('r = ',r1:6:2);
writeln ('R = ',r2:6:2);
end.
-------------------------------------------------------------------
Пример:
введите катет а: 4
введите катет b: 6
r = 1.39
R = 3.61
***значения округлены до 2 знаков после запятой
- 17.11.2017 05:09
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.