Вопрос по информатике:
Умоляююююююююююююююю
ПЛИИИИЗ
ТОЛЬКО НА ПАСКАЛЕЕЕЕЕ
Напишите функцию
bool Xor (bool x, bool y) (C/C++),
function _Xor (x, y:boolean): boolean (Pascal),
def xor(x, y):(Python)
реализующую функцию "Исключающее ИЛИ" двух логических переменных x и y. Функция Xor должна возвращать true, если ровно один из ее аргументов x или y, но не оба одновременно равны true.
Входные данные
Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).
Выходные данные
Необходимо вывести 0 или 1 - значение функции от x и y.
- 23.10.2017 15:00
- Информатика
- remove_red_eye 5610
- thumb_up 49
Ответы и объяснения 1
begin
_Xor:=xy;
end;
var x,y:byte;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
writeln(ord(_Xor(x=1,y=1)));
end.
Пример:
x = 1
y = 0
1
- 24.10.2017 04:38
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.