Вопрос по информатике:
Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от -50 до 50.
(Паскаль)
- 11.12.2015 04:30
- Информатика
- remove_red_eye 11741
- thumb_up 35
Ответы и объяснения 1
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Max=',a.Max)
end.
Пример
n= 13
-11 16 -24 5 5 3 42 45 -46 45 22 43 -4
Max=45
2. А так учат в большинстве школ...
const
nn=100;
var
a:array[1..nn] of integer;
i,n,max:integer;
begin
Write('n='); Read(n);
randomize;
max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i]
end;
Writeln;
Writeln('Max=',max)
end.
- 12.12.2015 13:32
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.