Вопрос по информатике:
Составьте программу,которая выполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 10,затем меняет местами первый элемент со вторым,третий с четвертым и т.д.
Выведите на экран исходный и полученный массивы.
- 10.08.2015 02:06
- Информатика
- remove_red_eye 836
- thumb_up 47
Ответы и объяснения 1
const
N = 10;
var
a: array [1..N] of integer;
i, temp: integer;
begin
randomize;
writeln('исходный массив: ');
for i := 1 to N do
begin
a[i] := Random(10);
write(a[i], ' ');
end;
writeln;
i := 1;
while i <= 9 do
begin
temp := a[i];
a[i] := a[i+1];
a[i+1] := temp;
i := i + 2;
end;
writeln('полученный массив: ');
for i := 1 to N do
write(a[i], ' ');
end.
- 11.08.2015 19:00
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.