Вопрос по информатике:
Составьте программу которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и определяет, есть ли в этом массиве хотя бы одно число, кратное трём
- 11.01.2018 09:19
- Информатика
- remove_red_eye 19907
- thumb_up 47
Ответы и объяснения 1
a: array [1..16] of integer;
i, c: integer;
begin
for i:=1 to 16 do
begin
a[i]:=random(-20,20);
Writeln('a[',i,']= ',a[i]);
end;
for i:=1 to 16 do
if (a[i] mod 3 = 0) then
c:=c+1;
if c > 0 then
Writeln('В получившемся массиве ', c, ' чисел, кратных трём.')
else
Writeln('В данном массиве нет чисел, кратных трём.');
end.
- 12.01.2018 12:24
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.