Вопрос по информатике:
Напишите программу, которая определяет, является ли заданная строка правильным IP-адресом.
на паскале
- 10.07.2018 16:25
- Информатика
- remove_red_eye 9540
- thumb_up 24
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadlnString('IP=').ToWords('.');
if a.Length4 then
Writeln('Адрес - это четыре числа, разделенные точками')
else begin
var n:integer;
foreach var c in a do begin
if not TryStrToInt(c,n) then begin
Writeln(c,'- не целое число'); exit end
else
if n>255 then begin Writeln(c,' превышает 255'); exit end;
end;
Writeln('IP-адрес корректен')
end
end.
Примеры
IP= 128.16.35.a4
a4- не целое число
IP= 240.127.56.340
340 превышает 255
IP= 34.56.42,5
Адрес - это четыре числа, разделенные точками
IP= 128.0.0.255
IP-адрес корректен
- 11.07.2018 06:00
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.