Вопрос по информатике:
Помогите пожалуйста)
1)Оценки в соревнованиях по фигурному катанию выставляются 9 судьями.Потом одна самая низкая и одна самая высокая оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок.Составьте программу,которая определяет зачетную оценку спортсмена.Оценки судей ввести с клавиатуры(целые числа от 1 до 6).
var
max,min,i:integer;
b:real;
a:array[1..9]of integer;
begin
for i:=1 to 9 do
begin
while (a[i]<1) or (a[i]>6) do
begin
write(i,' оценка: ');
readln(a[i]);
end;
if i=1 then
begin
max:=a[1];
min:=a[1];
end;
if a[i]>max then max:=a[i];
if a[i] b:=b+a[i];
end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end.
что тут не так
- 14.05.2017 09:06
- Информатика
- remove_red_eye 10674
- thumb_up 34
Ответы и объяснения 2
это к чему? где then?
максимум находишь и аналогично минимум.
для чистоты кода ещё бы б=0 в начале.
такие дела. програмЬ!
- 15.05.2017 16:07
- thumb_up 10
- 16.05.2017 05:33
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.