Вопрос по информатике:
Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. Исходные данные должны вводиться во время работы программы. Рекомендуемый вид экрана во время работы программы приведен ниже (данные, введенные пользователем, выделены полужирным шрифтом).
Введите температуру воздуха за неделю.
Понедельник -> 12
Вторник -> 10 '
Среда -> 16
Четверг -> 18
Пятница -> 17
Суббота -> 16
Воскресенье -> 14
Средняя температура за неделю: 14.71 град.
- 27.06.2017 04:51
- Информатика
- remove_red_eye 15531
- thumb_up 25
Ответы и объяснения 1
a: array[1..7] of string = ('Понедельник', 'Вторник', 'Среда', 'Четверг', 'Пятница', 'Суббота', 'Воскресенье');
av: real; i, t: integer;
begin
writeln('Введите температуру воздуха за неделю.');
for i := 1 to 7 do
begin
write(a[i], ' -> '); readln(t); av := av + t;
end;
av := av / 7;
writeln('Средняя температура за неделю: ', av:0:2, ' град.');
readln;
end.
- 28.06.2017 05:41
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.